Arduino based Blend Micro gives error: Device Descriptor Request Failed in Device Manager

So I started to fiddle around with the Red Bear Lab Blend Micro. All seemed ok, but after I had uploaded a sketch, the device stopped being recognized properly.

The Device Manager in Windows gives me an error message saying Device Descriptor Request Failed:

Device Descriptor Request Failed
Device Descriptor Request Failed

Well, several other blog posts suggests that re-installing the device drivers will help. But that’s really not helping.

The issue seems to be that the device is not responding and communicating properly with the connected USB host for whatever reason when the sketch is running. Let’s see if we manage to revert back to an empty default sketch.┬áThe Blend Micro device has a window of 8 seconds from booting until it starts running the loaded sketch. During that time frame, we should be able to upload a default sketch.

First, make sure that the Blend Micro is the selected board in the Arduino IDE:

Blend Micro is selected
Blend Micro is selected

Prepare a sketch with the base minimum code:

Then reboot the Blend Micro device by pressing the reset button.

Reset button on the Blend Micro
Reset button on the Blend Micro

The timing can be critical, so you probably have to try multiple times to get it right. A tip is to click the Upload first, wait a half of a second and then press the reset button.

 

Leave a Reply

Your email address will not be published. Required fields are marked *